Sitecore 9 Installation Error: ERROR_SCRIPTDOM_NEEDED_FOR_SQL (The SQL provider cannot run because of missing dependency. Please make sure that Microsoft SQL Server Transact-SQL ScriptDom is installed)

Sitecore 9 Installation Error: ERROR_SCRIPTDOM_NEEDED_FOR_SQL (The SQL provider cannot run because of missing dependency. Please make sure that Microsoft SQL Server Transact-SQL ScriptDom is installed). 


Few days ago, I thought to install Sitecore 9 while I was installing Sitecore 9 I faced this issue:







 after some research I found this solution.



  1. Go to Run and type “regedit”
  2. Go to this location “Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\IIS Extensions\MSDeploy\3”
  3. Right click on right hand side, select New->String Value.
  4. Type name “DacFxDependenciesPath”
  5. Then click on Name then Modify and update Value Data “C:\Program Files (x86)\Microsoft SQL Server\130\SDK\Assemblies”
  6. Again, right click on right hand side, select New->String Value.
  7. Type name “DacFxPath”
  8. Then click on Name then Modify and update Value Data “C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\SQLDB\DAC\130”




Then run script again. It will work 😊




Comments

Popular Posts